Errors / warnings after sync

Installing HAAst, prerequisites, getting HAAst started, and troubleshooting performance and technical issues. As well, upgrades to HAAst and any underlying software.
Post Reply
User avatar
CRM User
Posts: 171
Joined: Sun Nov 27, 2016 3:41 pm

Errors / warnings after sync

Post by CRM User » Wed May 08, 2019 10:55 pm

I have setup sync but I'm getting warnings and errors in the haast log file like this:

Code: Select all

Result code '0'. Error code '5'. Exit code '10'.  Enable debug for further details.
Result code '0'. Error code '5'. Exit code '5'.  Enable debug for further details.
I've been playing with the settings and I thought I was close but am stuck on the second error message now.
Account for questions transferred from CRM system
User avatar
Telium Support
Posts: 225
Joined: Sun Nov 27, 2016 3:27 pm

Re: Errors / warnings after sync

Post by Telium Support » Wed May 08, 2019 10:58 pm

The first error means that the rsync process is not running. Please ensure rsync is installed, running, enabled, and configured as per the HAAst detailed installation guide.

I suspect that you actually solved the first error, since the second error means that rsync is running! But, the second error means that the rsync.haast.secret file has the wrong permissions. Please modify the permissions of this file as follows:
chmod 600 /etc/ rsync.haast.secret
After that your sync should work.
User avatar
Telium Support
Posts: 225
Joined: Sun Nov 27, 2016 3:27 pm

Re: Errors / warnings after sync

Post by Telium Support » Thu May 23, 2019 1:25 pm

Some addition exit codes and their causes:

255 - Likely a connection problem to the remote host. Check the IP address / fqdn of the remote host
23 - Error during transfer. Check the file/directory being synced really exists on the source.
Post Reply