Search found 135 matches

by CRM User
Sun Jun 24, 2018 2:09 pm
Forum: Configuration & Optimization
Topic: Run result 3 when starting FreePBX on old hardware
Replies: 1
Views: 101

Run result 3 when starting FreePBX on old hardware

I'm running FreePBX on a couple of old servers for testing. I installed HAAst and although everything seems to work, I sometimes see this error after failing over the cluster: Sat Jun 23 23:02:23 2018, 00000721, E, System Command, Failed to start Asterisk (start) wrapper. Run result 3; exitcode 0 Wh...
by CRM User
Mon May 21, 2018 3:03 pm
Forum: Installation & Upgrade
Topic: Moving PBX between VM hosts in a data center
Replies: 1
Views: 257

Moving PBX between VM hosts in a data center

We have our primary PBX's (3 of them) running in our data center, and the backup PBX's (3 of them) running in the cloud on AWS. How would this work for licensing? (Its important that the VM's can move between hosts in our data center and in AWS).
by CRM User
Thu May 17, 2018 2:23 pm
Forum: Installation & Upgrade
Topic: What should I do with the new license file?
Replies: 1
Views: 161

What should I do with the new license file?

You sent me a new license file called haast.25441.license after I renewed my maintenance agreement. What do I do with this file? I already have a file called haast.license in my /usr/local/haast directory and everything is working fine.
by CRM User
Sat Apr 28, 2018 3:35 am
Forum: Configuration & Optimization
Topic: HAAst can't connect to Asterisk / AMI
Replies: 1
Views: 178

HAAst can't connect to Asterisk / AMI

My new HAAst installation keeps promoting and demoting because it doesn't think that Asterisk is running. I confirmed the Asterisk AMI is running: [root@pbx1texas:~] $ netstat -anp | grep 5038 tcp 0 0 127.0.0.1:5038 0.0.0.0:* LISTEN 31671/asterisk and I confirmed that the haast.conf file, in the [as...
by CRM User
Thu Apr 19, 2018 4:51 am
Forum: Installation & Upgrade
Topic: Killed / Not an executable error on start
Replies: 1
Views: 325

Killed / Not an executable error on start

When I start SecAst it dies right away with the warning "Killed" $ ./secast -f Killed So I checked the executable using the loader and it says SecAst is not an executable $ ldd ./secast not a dynamic executable What is wrong? The exact same executable (I copied it using scp) runs great on my first v...
by CRM User
Fri Apr 06, 2018 1:10 pm
Forum: General
Topic: Asterisk beta compatibility
Replies: 1
Views: 273

Asterisk beta compatibility

I need some leading edge features from an Asterisk beta and want to use HAAst. (We run HAAst for our production PBX's now - this is for an unrelated project).

Can you support this deployment?
by CRM User
Thu Apr 05, 2018 3:18 pm
Forum: Installation & Upgrade
Topic: Asterisk won't start, can't connect to Asterisk console with '-r' parameter
Replies: 1
Views: 384

Asterisk won't start, can't connect to Asterisk console with '-r' parameter

I have setup HAAst correctly and I see that HAAst attempts to start Asterisk. However, it appears that Asterisk fails to start. I have narrowed this down to a permissions issue, and Asterisk is unable to create the pid file in /var/run/asterisk/ As a result I can't connect to Asterisk using the 'ast...
by CRM User
Thu Apr 05, 2018 1:17 pm
Forum: Configuration & Optimization
Topic: Lost AMI connection caused failover
Replies: 1
Views: 264

Lost AMI connection caused failover

This morning I found my cluster had failed over to the backup data center (during the night). Around that time I see an error in the haast log that the remote peer lost connection to the AMI. But, I can confirm that Asterisk was still running. I sent you my Asterisk logs and HAAst logs by email. Can...
by CRM User
Mon Mar 26, 2018 3:54 pm
Forum: Configuration & Optimization
Topic: Lose contact with PBX when node is active
Replies: 1
Views: 434

Lose contact with PBX when node is active

I am setting up a small office PBX cluster. My network settings are: Active Node: IP 192.168.1.1, Netmask 255.255.255.0 Passive Node: IP 192.168.1.2, Netmask 255.255.255.0 VoIP NIC: IP 192.168.1.3, Netmask 255.255.255.0 When either node goes active I lose contact with it - sometimes, from some phone...
by CRM User
Sun Mar 25, 2018 1:05 pm
Forum: Configuration & Optimization
Topic: No option to configure gateway for VoIP NIC
Replies: 1
Views: 353

No option to configure gateway for VoIP NIC

I am using the [voipnic] settings in haast.conf and am able to successfully create a vNIC with an address on my vLAN. The command ifconfig shows: eth0.haast: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500 inet 10.10.0.4 netmask 255.255.255.0 broadcast 10.10.0.255 ether 02:22:5d:f2:28:ac txqueue...